Jump to content
gav240z

OEM antenna rebuild (Harada) - Step by Step Guide w/photos.

Recommended Posts

Hi Folks,

I'm documenting my OEM antenna rebuild.

This thread served as a good example, but I felt lost before I started on my own when looking at it and felt it was missing some details.

https://www.classiczcars.com/forums/topic/46443-antenna-rebuild-restore/

If you find your nylon string is broken.. This thread may be a solution (I haven't tried this yet).

https://www.classiczcars.com/forums/topic/39699-antenna-mast-plastic-string-replacement/?&page=2#comments

So anyway I bought this antenna from YAJ! a couple of years ago. Condition unknown, but it had the "arrow" tip antenna end that early cars had. So I assumed it was from an early S30Z. But there really isn't any markings on it to state it's a "harada" type or hitachi type antenna.

But I assume it's a similar process to rebuild it for most of these antenna's. Since they probably all work or are made from the same original licence, kind of like we got Hitachi branded SUs and Nikki/Atsugi fuel pumps which were basically the same except for casting / branding marks.

Anyway I digress...

Step 1.

harada1.jpg 

Remove the nut and (1) washer.

Step 2. This will reveal the winding assembly, which has 1 washer underneath also. Remove the washers and set them aside.

harada2.jpg

Step 3.

harada3.jpg

You can see a pin that holds the plastic/nylon chord in place to the assembly. You'll need pliers to straighten them out and be able to remove it. (Similar to castle nuts on ball joints).

Step 4.

harada4.jpg

There is an e-clip that is holding on the assembly, a small flat head screw driver should be able to pry it off. There is 3 washers underneath that. Set them aside.

harada5.jpg

harada6.jpg

Step 5. You should now be able to move the winder assembly.

harada7.jpg

There is a black dust cover/plastic shield underneath. I believe there was 1 screw I needed to remove but it's very fragile and was already a little broken. So be very careful removing it.

Step 6.

harada8.jpg

Underneath the assembly you can see the gear that is turned which in turn moves the nylon string and pushes the antenna up and out.

Step 7.

harada9.jpg

There is a locking screw on the outside body, this holds in the black plastic retainer that the nylon string runs underneath of.

Step 8. I knew this would happen, I tried to gently pry up the black plastic bit, but it broke.. I think the amount of gunk / rust and rubbish in the area had seized it into the body. You might try WD40 or another penetrating lube spray if you give yours a go and may be able to save it from being broken.

harada10.jpg

Step 9.

harada11.jpg

It broke right on the screw hole line.

harada12.jpg

I should be able to glue it back together for reassembly..

Step 10.

Look at all this gunk..this is causing the nylon string to bind up and stop moving..

harada13.jpg

Step 11. The antenna mast itself is held in with 2 screws at the base. I removed them, but still can't separate the motor body and mast yet!

harada14.jpg

Step 12. At the bottom of the housing is a retaining / locking nut.

harada15.jpg

harada16.jpg

This allows you to remove the screw at the base of the motor shaft that spins.

harada17.jpg

harada18.jpg

Step 13. You can remove the nut at the top of the mast, keep track of the order of the rubber/finisher/trim bits. These are now being thankfully reproduced by www.240zrubberparts.com

https://www.240zrubberparts.com/apps/webstore/products/show/7708630

https://www.240zrubberparts.com/apps/webstore/products/show/7705446

harada19.jpg

Step 14. I still can't separate the housing and mast assembly, they seem to have binded together.

harada20.jpg

harada21.jpg

The other problem is I can extend the antenna itself, but only the top and bottom portions. The middle sections won't extend and seems to have rusted/sized up. I don't want to force them apart either. I may try some penetrating spray and a heat gun or torch to free it up. But not sure what's the best way to go without breaking it!

Step 15. The motor assembly itself.

First polarity photos for later reference, since you need to de-solder these points to remove the loom from the housing.

harada22.jpg

harada23.jpg

Step 15. Cleaning the motor commutator and brush assembly.

harada24.jpg

harada25.jpg

Can you see the black carbon mark on the round cylinderical brass thing? Well I used this lube/spray/cleaner.

harada26.jpg

Yes I should have put a rag down to prevent spillage on the wooden desk! Don't be like me.

I used q-tips/cotton buds to clean the carbon marks off the motor and you can see how dirty the tips got!

harada27.jpg

You can push the spring left and right to clean the commutator surface!

I should have taken video before, the motor would turn, but very slowly... and it would go slow, faster, slow, faster..

However after cleaning it up you can see it moves quickly now! Like someone put a rocket up it's dress.

So next steps are to possibly get the housing/body vapour blasted and fasteners plated etc.. and then lube up the assembly with grease and re-assemble and hope it all works nicely.

There was so much crud and gunk down the bottom of the assembly/body that it was preventing the nylon / string from moving in the body. So it's no wonder it stopped working.

PS: If anyone has spare antenna assemblies/broken or otherwise, please let me know?

Share this post


Link to post
Share on other sites

So I managed to get the antenna out.

I sprayed some of this..

IMG20200625180149.jpg

Into the channel here.

IMG20200625180141.jpg

Where I'm pointing.

IMG20200625180128.jpg

This part was catching so I had to use a screw driver to push it down into the channel and thread it past.

You can see it apart here.

But I couldn't get all antenna extensions to extend. I sprayed a lot of the liquid wrench into the antenna tip and have let it soak. I used a propane torch to lightly heat it up, but still wouldn't budge.

So I may soak it in oil or similar.. but need to be very gentle since these are so easy to snap / break otherwise.

IMG20200625180221.jpg

IMG20200625180122.jpg

I also cannot yet separate the long antenna mast tube from the body of the assembly. It's like an interference fit. Also tried heat here to no avail yet.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...