Jump to content
Gadget007a

First Startup after 15+ years

Recommended Posts

Not sure if this is the right place to post happy for this to be moved.

I am about to get started on a fix up of the old girl, has't been run for over 15 years, so today I

 took off the rocker cover and was pleasantly surprised how clean it was there even was a small amount of oil on the cam shaft. 

Using a borescope in each cylinder I couldn't see any corrosion I could even see the hone marks from when it was rebuilt previously.

Anyway i poured some new oil over the cam, removed the spark plugs and gave each cylinder a small squirt of oil.  spun the engine over by hand, then on the starter with no plugs installed.

Re-installed the spark plugs, poured some fuel into each carb.  

Turned the key an she fired straight up.

before i put her in storage i drained the oil and put in fresh oil and new filter, drained the radiator and i think i put a little bit of oil in each cylinder.

 

Share this post


Link to post
Share on other sites

I revived my 71 auto after a long slumber. It's a good feeling seeing the motor spin over freely and happily after sitting silently for so long.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...