Jump to content
JDM-TOY

Spindle Pins Not Going In

Recommended Posts

Hey Guys 

Just had a look in this section but I couldn't find anything with people having issues with fitting their spindle pins in. 

So I have had the rear control arms painted, struts powder coated and the pins brass enamel coted. 

We tried to fiddle around and slide the pins in a little but they wouldn't go in both the struts or  the control arms. Could the coating be the issue or ar they generally difficult to get in. 

Just worried they wont go in at all on Monday and then we would need to sandblast the pins to see if they fit. Anyone have a issue with theirs 

Cheers

Youhan

Share this post


Link to post
Share on other sites

Thanks Lachlan @Lurch I filed off the enamel coating and they slid right in. Dont know why I got them coated as you cant even see them. Should have just done the nuts. 

Cheers

Youhan

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...