Jump to content
JDM-TOY

Spindle Pins Not Going In

Recommended Posts

Hey Guys 

Just had a look in this section but I couldn't find anything with people having issues with fitting their spindle pins in. 

So I have had the rear control arms painted, struts powder coated and the pins brass enamel coted. 

We tried to fiddle around and slide the pins in a little but they wouldn't go in both the struts or  the control arms. Could the coating be the issue or ar they generally difficult to get in. 

Just worried they wont go in at all on Monday and then we would need to sandblast the pins to see if they fit. Anyone have a issue with theirs 

Cheers

Youhan

Share this post


Link to post
Share on other sites

They are a very snug fit and need to be clean to slide in. A tap with a soft face hammer should get them in. i suspect yours are now oversize.

Share this post


Link to post
Share on other sites
20 minutes ago, JDM-TOY said:

... and the pins brass enamel coated. 

^ Issue Found ^

Share this post


Link to post
Share on other sites
1 hour ago, Lurch said:

^ Issue Found ^

Thanks Lachlan I will sort them out on Monday, lets see how I go

Share this post


Link to post
Share on other sites

Thanks Lachlan @Lurch I filed off the enamel coating and they slid right in. Dont know why I got them coated as you cant even see them. Should have just done the nuts. 

Cheers

Youhan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×