Jump to content


Photo

260Z Rich/rough Running After Filling Up. L28 Carb


  • Please log in to reply
4 replies to this topic

#1 manyu

manyu

    Member

  • Members
  • PipPip
  • 10 posts
  • Location:Sydney

Posted 15 January 2016 - 08:46 PM

Hi guys, been having a few troubles with getting the car to run right ever since I got it. 
It's a 2+2 with an L28 that's been converted to carb. 

 

I've noticed only recently (last two fill ups) car runs extremely rich after it's been filled up and it gradually gets better as the tank level keeps dropping. I noticed this due to the fact that the fuel smell inside the cabin when driving gets noticeably higher/unbearable right after filling up. 

Does this sound like a faulty fuel pump or a pressure issue? I'd be interested in putting a fuel pressure regulator in with a guage to get a better idea as to what's happening. 

What regulators are people using and where do you buy them from?

Cheers.



#2 Retro Z

Retro Z

    The 1000+ club

  • Members
  • PipPipPipPipPipPip
  • 1,398 posts
  • Location:Melbourne, western suburbs
  • Tagline:73' 240z and 72’ 240z

Posted 15 January 2016 - 09:32 PM

Sounds like its just the fuel vapours venting from the vent hose or filler neck leading to the petrol smell in cabin after filling.

Is your engine running the mechanical fuel pump?

#3 manyu

manyu

    Member

  • Members
  • PipPip
  • 10 posts
  • Location:Sydney

Posted 15 January 2016 - 09:40 PM

Don't think it's the vent hose as the fumes are not constant, it's only after you've been flogging it. It's running an electric pump near the tank, not mechanical.



#4 ilbert

ilbert

    Advanced Member

  • Members
  • PipPipPip
  • 176 posts
  • Location:melbourne
  • Tagline:New Member

Posted 16 January 2016 - 05:42 PM

Have you crawled under and checked the vent hose? I have a similar issue, if I fill the tank totally it leaks slightly at the vent hose.I'll replace it as per recent posts. Enthusiastic driving may be sloshing the fuel around.

#5 manyu

manyu

    Member

  • Members
  • PipPip
  • 10 posts
  • Location:Sydney

Posted 18 January 2016 - 12:31 PM

Checked the vent hose, not leaking. The fumes I'm complaining about are exhaust fumes, only happens after hard acceleration when near full tank. Doesn't happen below half tank. 

Think my main issue here is that the car is RUNNING noticeably richer on a full tank of petrol, fumes are a secondary issue. Hoping someone can shed light on why it'd only run rich when it's got a full tank of petrol. 

Cheers.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users